Skip to main content
← All vulnerabilities
CVE-2024-34341GHSA-QJQP-XR96-CJ99

The Trix Editor Contains an Arbitrary Code Execution Vulnerability

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.1.1, 1.3.2, 7.0.8.3, 7.1.3.3
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Trix is a rich text editor. The Trix editor, versions prior to 2.1.1, is vulnerable to arbitrary code execution when copying and pasting content from the web or other documents with markup into the editor. The vulnerability stems from improper sanitization of pasted content, allowing an attacker to embed malicious scripts which are executed within the context of the application. Users should upgrade to Trix editor version 2.1.1 or later, which incorporates proper sanitization of input from copied content.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • basecamp trix

    fixed in 2.1.1

  • trixnpm

    From 2.0.0 · fixed in 2.1.1

  • trixnpm

    From 0.9.0 · fixed in 1.3.2

  • actiontextRubyGems

    From 7.0.0.alpha1 · fixed in 7.0.8.3

  • actiontextRubyGems

    From 7.1.0.beta1 · fixed in 7.1.3.3

References 6

GitHub · basecamp/trix