Skip to main content
← All vulnerabilities
CVE-2024-34111GHSA-JMQP-R3GG-6JH3BIT-MAGENTO-2024-34111

SSRF in service connector

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.4.6-p6, 2.4.5-p8, 2.4.4-p9
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Adobe Commerce versions 2.4.7, 2.4.6-p5, 2.4.5-p7, 2.4.4-p8 and earlier are affected by a Server-Side Request Forgery (SSRF) vulnerability that could lead to arbitrary file system read. A low-privilege authenticated attacker can force the application to make arbitrary requests via injection of arbitrary URLs. Exploitation of this issue does not require user interaction..

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • Adobe Adobe Commerce

    through 2.4.4-p8

  • magento/community-editionPackagist

    2.4.7

  • magento/community-editionPackagist

    2.4.6

  • magento/community-editionPackagist

    2.4.5

  • magento/community-editionPackagist

    2.4.4

  • magento/community-editionPackagist

    From 2.4.6-p1 · fixed in 2.4.6-p6

  • magento/community-editionPackagist

    From 2.4.5-p1 · fixed in 2.4.5-p8

  • magento/community-editionPackagist

    fixed in 2.4.4-p9

References 1

helpx.adobe.com