Skip to main content
← All vulnerabilities
CVE-2024-34107GHSA-R7CM-G469-WM4GBIT-MAGENTO-2024-34107

Adobe Commerce | Improper Access Control (CWE-284)

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.4.6-p6, 2.4.5-p8, 2.4.4-p9
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: total

Summary

Adobe Commerce versions 2.4.7, 2.4.6-p5, 2.4.5-p7, 2.4.4-p8 and earlier are affected by an Improper Access Control vulnerability that could result in a Security feature bypass. An attacker could leverage this vulnerability to bypass security measures and view minor unauthorised information. Exploitation of this issue does not require user interaction.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: total

  3. Record last updated

Affected versions

  • Adobe Adobe Commerce

    through 2.4.4-p8

  • magento/community-editionPackagist

    2.4.7

  • magento/community-editionPackagist

    2.4.6

  • magento/community-editionPackagist

    2.4.5

  • magento/community-editionPackagist

    2.4.4

  • magento/community-editionPackagist

    From 2.4.6-p1 · fixed in 2.4.6-p6

  • magento/community-editionPackagist

    From 2.4.5-p1 · fixed in 2.4.5-p8

  • magento/community-editionPackagist

    fixed in 2.4.4-p9

References 1

helpx.adobe.com