Skip to main content
← All vulnerabilities
CVE-2024-34106GHSA-P6H9-GX5G-WG64BIT-MAGENTO-2024-34106

Insecure Direct Object Reference - An attacker can able to erase the victim quote details

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.4.6-p6, 2.4.5-p8, 2.4.4-p9
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

Adobe Commerce versions 2.4.7, 2.4.6-p5, 2.4.5-p7, 2.4.4-p8 and earlier are affected by an Incorrect Authorization vulnerability that could result in a security feature bypass. An attacker could exploit this vulnerability to gain unauthorized access or perform actions with the privileges of another user. Exploitation of this issue does not require user interaction.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  3. Record last updated

Affected versions

  • Adobe Adobe Commerce

    through 2.4.4-p8

  • magento/community-editionPackagist

    2.4.7

  • magento/community-editionPackagist

    2.4.6

  • magento/community-editionPackagist

    2.4.5

  • magento/community-editionPackagist

    2.4.4

  • magento/community-editionPackagist

    From 2.4.6-p1 · fixed in 2.4.6-p6

  • magento/community-editionPackagist

    From 2.4.5-p1 · fixed in 2.4.5-p8

  • magento/community-editionPackagist

    fixed in 2.4.4-p9

References 1

helpx.adobe.com