CVE-2024-34104GHSA-WWJ3-573J-RVVMBIT-MAGENTO-2024-34104
Adobe Commerce | Improper Authorization (CWE-285)
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.4.6-p6, 2.4.5-p8, 2.4.4-p9
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
CISA's decision points: whether it is exploited, whether attacks can be automated, and how much control an attacker gets. Assessed (SSVC 2.0.3).What do these mean? →
- Exploitation: none
- Automatable: yes
- Technical impact: total
Summary
Adobe Commerce versions 2.4.7, 2.4.6-p5, 2.4.5-p7, 2.4.4-p8 and earlier are affected by an Improper Authorization vulnerability that could result in a Security feature bypass. An attacker could leverage this vulnerability to bypass security measures and gain unauthorized access, leading to both confidentiality and integrity impact. Exploitation of this issue does not require user interaction.
Timeline
- CVE published
- CISA SSVC assessment
Exploitation: none · Automatable: yes · Technical impact: total
- Record last updated
Affected versions
- Adobe Adobe Commerce
through 2.4.4-p8
- magento/community-editionPackagist
2.4.7
- magento/community-editionPackagist
2.4.6
- magento/community-editionPackagist
2.4.5
- magento/community-editionPackagist
2.4.4
- magento/community-editionPackagist
From 2.4.6-p1 · fixed in 2.4.6-p6
- magento/community-editionPackagist
From 2.4.5-p1 · fixed in 2.4.5-p8
- magento/community-editionPackagist
fixed in 2.4.4-p9