Skip to main content
← All vulnerabilities
CVE-2024-34001GHSA-GQ9F-8RJ4-W7JCBIT-MOODLE-2024-34001

moodle: CSRF risk in admin preset tool management of presets

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 4.3.4, 4.2.7, 4.1.10
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Actions in the admin preset tool did not include the necessary token to prevent a CSRF risk.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • Moodle

    From 4.0 · through 4.3.3; From 4.2 · through 4.2.6; From 4.1 · through 4.1.9

  • moodle/moodlePackagist

    From 4.3.0 · fixed in 4.3.4

  • moodle/moodlePackagist

    From 4.2.0 · fixed in 4.2.7

  • moodle/moodlePackagist

    fixed in 4.1.10

References 1

moodle.org