Skip to main content
← All vulnerabilities
CVE-2024-33522GO-2024-2801GHSA-6362-GV4M-53WW

Privilege escalation in Calico CNI install binary

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in v3.26.5, v3.27.3, v3.17.4, v3.18.2, v3.19.0-2.0, and 3 more
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

In vulnerable versions of Calico (v3.27.2 and below), Calico Enterprise (v3.19.0-1, v3.18.1, v3.17.3 and below), and Calico Cloud (v19.2.0 and below), an attacker who has local access to the Kubernetes node, can escalate their privileges by exploiting a vulnerability in the Calico CNI install binary. The issue arises from an incorrect SUID (Set User ID) bit configuration in the binary, combined with the ability to control the input binary, allowing an attacker to execute an arbitrary binary with elevated privileges.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • cni-plugin

    fixed in v3.26.5; From v3.27.0 · fixed in v3.27.3

  • cni-plugin

    fixed in v3.17.4; From v3.18.0 · fixed in v3.18.2; From v3.19.0-1.0 · fixed in v3.19.0-2.0

  • cni-plugin

    fixed in v19.3.0

  • github.com/projectcalico/calicoGo

    All versions

  • github.com/projectcalico/calico/v3Go

    All versions

  • github.com/projectcalico/calicoGo

    fixed in 3.26.5

  • github.com/projectcalico/calicoGo

    From 3.27.0 · fixed in 3.27.3

References 4

GitHub · projectcalico/calico

tigera.io