Skip to main content
← All vulnerabilities
CVE-2024-3204

c-blosc2 ndlz4x4.c ndlz4_decompress heap-based overflow

Published
Last modified
published
Not listed in CISA KEV
Fix
Fix or patch referenced
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

A vulnerability has been found in c-blosc2 up to 2.13.2 and classified as critical. Affected by this vulnerability is the function ndlz4_decompress of the file /src/c-blosc2/plugins/codecs/ndlz/ndlz4x4.c. The manipulation leads to heap-based buffer overflow. The attack can be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 2.14.3 is able to address this issue. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-259051.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  3. Record last updated

Affected versions

  • n/a c-blosc2

    2.13.0, 2.13.1, 2.13.2

References 5

vuldb.com

drive.google.com

GitHub · Blosc/c-blosc2