Skip to main content
← All vulnerabilities
CVE-2024-3180GHSA-9QHC-PG6J-WF23

Concrete CMS version 9 below 9.2.8 and previous versions below 8.5.16 is vulnerable to Stored XSS in blocks of type file

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 9.2.8, 8.5.16
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Concrete CMS version 9 below 9.2.8 and previous versions below 8.5.16 is vulnerable to Stored XSS in blocks of type file. Stored XSS could be caused by a rogue administrator adding malicious code to the link-text field when creating a block of type file. The Concrete CMS security team gave this vulnerability a CVSS v3.1 score of 3.1 with a vector of AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:L/A:L https://nvd.nist.gov/vuln-metrics/cvss/v3-calculator . Thanks Alexey Solovyev for reporting.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Concrete CMS Concrete CMS

    From 9.0.0 · fixed in 9.2.8; From 5.0.0 · fixed in 8.5.16

  • concrete5/concrete5Packagist

    From 9.0.0RC1 · fixed in 9.2.8

  • concrete5/concrete5Packagist

    fixed in 8.5.16

References 2

documentation.concretecms.org