Skip to main content
← All vulnerabilities
CVE-2024-28824

Privilege escalation in mk_informix plugin

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.3.0b4, 2.2.0p24, 2.1.0p41
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Least privilege violation and reliance on untrusted inputs in the mk_informix Checkmk agent plugin before Checkmk 2.3.0b4 (beta), 2.2.0p24, 2.1.0p41 and 2.0.0 (EOL) allows local users to escalate privileges.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • Checkmk GmbH Checkmk

    From 2.3.0 · fixed in 2.3.0b4; From 2.2.0 · fixed in 2.2.0p24; From 2.1.0 · fixed in 2.1.0p41; From 2.0.0 · through 2.0.0p39

References 1

checkmk.com