Skip to main content
← All vulnerabilities
CVE-2024-28746PYSEC-2024-46BIT-AIRFLOW-2024-28746GHSA-H574-6646-VFXX

Apache Airflow: Ignored Airflow Permissions

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.8.3, 2.8.3rc1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Apache Airflow, versions 2.8.0 through 2.8.2, has a vulnerability that allows an authenticated user with limited permissions to access resources such as variables, connections, etc from the UI which they do not have permission to access.  Users of Apache Airflow are recommended to upgrade to version 2.8.3 or newer to mitigate the risk associated with this vulnerability

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • apache-airflow

    From 2.8.0 · fixed in 2.8.3

  • apache-airflowPyPI

    From 2.8.0 · fixed in 2.8.3rc1

References 3

GitHub · apache/airflow

lists.apache.org

openwall.com